29 Mei 2010

Pengenalan dan Instalasi Mikrotik

MikroTik RouterOS™ adalah sistem operasi linux yang dapat digunakan untuk menjadikan komputer menjadi router network yang handal, mencakup berbagai fitur yang dibuat untuk ip network dan jaringan wireless, cocok digunakan oleh ISP dan provider hostspot.

Fitur² yang terdapat dalam mikrotik.

* Firewall and NAT - stateful packet filtering; Peer-to-Peer protocol filtering; source and destination NAT; classification by source MAC, IP addresses (networks or a list of networks) and address types, port range, IP protocols, protocol options (ICMP type, TCP flags and MSS), interfaces, internal packet and connection marks, ToS (DSCP) byte, content, matching sequence/frequency, packet size, time and more...

* Routing - Static routing; Equal cost multi-path routing; Policy based routing (classification done in firewall); RIP v1 / v2, OSPF v2, BGP v4

* Data Rate Management - Hierarchical HTB QoS system with bursts; per IP / protocol / subnet / port / firewall mark; PCQ, RED, SFQ, FIFO queue; CIR, MIR, contention ratios, dynamic client rate equalizing (PCQ), bursts, Peer-to-Peer protocol limitation

* HotSpot - HotSpot Gateway with RADIUS authentication and accounting; true Plug-and-Play access for network users; data rate limitation; differentiated firewall; traffic quota; real-time status information; walled-garden; customized HTML login pages; iPass support; SSL secure authentication; advertisement support

* Point-to-Point tunneling protocols - PPTP, PPPoE and L2TP Access Concentrators and clients; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; MPPE encryption; compression for PPPoE; data rate limitation; differentiated firewall; PPPoE dial on demand

* Simple tunnels - IPIP tunnels, EoIP (Ethernet over IP)

* IPsec - IP security AH and ESP protocols; MODP Diffie-Hellman groups 1,2,5; MD5 and SHA1 hashing algorithms; DES, 3DES, AES-128, AES-192, AES-256 encryption algorithms; Perfect Forwarding Secrecy (PFS) MODP groups 1,2,5

* Proxy - FTP and HTTP caching proxy server; HTTPS proxy; transparent DNS and HTTP proxying; SOCKS protocol support; DNS static entries; support for caching on a separate drive; access control lists; caching lists; parent proxy support

* DHCP - DHCP server per interface; DHCP relay; DHCP client; multiple DHCP networks; static and dynamic DHCP leases; RADIUS support

* VRRP - VRRP protocol for high availability

* UPnP - Universal Plug-and-Play support

* NTP - Network Time Protocol server and client; synchronization with GPS system

* Monitoring/Accounting - IP traffic accounting, firewall actions logging, statistics graphs accessible via HTTP

* SNMP - read-only access

* M3P - MikroTik Packet Packer Protocol for Wireless links and Ethernet

* MNDP - MikroTik Neighbor Discovery Protocol; also supports Cisco Discovery Protocol (CDP)

* Tools - ping; traceroute; bandwidth test; ping flood; telnet; SSH; packet sniffer; Dynamic DNS update tool

Layer 2 connectivity

* Wireless - IEEE802.11a/b/g wireless client and access point (AP) modes; Nstreme and Nstreme2 proprietary protocols; Wireless Distribution System (WDS) support; virtual AP; 40 and 104 bit WEP; WPA pre-shared key authentication; access control list; authentication with RADIUS server; roaming (for wireless client); AP bridging

* Bridge - spanning tree protocol; multiple bridge interfaces; bridge firewalling, MAC

* VLAN - IEEE802.1q Virtual LAN support on Ethernet and wireless links; multiple VLANs; VLAN bridging

* Synchronous - V.35, V.24, E1/T1, X.21, DS3 (T3) media types; sync-PPP, Cisco HDLC, Frame Relay line protocols; ANSI-617d (ANDI or annex D) and Q933a (CCITT or annex A) Frame Relay LMI types

* Asynchronous - s*r*al PPP dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; onboard s*r*al ports; modem pool with up to 128 ports; dial on demand

* ISDN - ISDN dial-in / dial-out; PAP, CHAP, MSCHAPv1 and MSCHAPv2 authentication protocols; RADIUS authentication and accounting; 128K bundle support; Cisco HDLC, x75i, x75ui, x75bui line protocols; dial on demand

* SDSL - Single-line DSL support; line termination and network termination modes


Instalasi Mikrotik.

Instalasi dapat dilakukan pada Standard computer PC.
PC yang akan dijadikan router mikrotikpun tidak memerlukan resource yang cukup besar untuk penggunaan standard, misalnya hanya sebagai gateway. Berikut spec minimalnya:

* CPU and motherboard - bisa pake P1 ampe P4, AMD, cyrix asal yang bukan multi-prosesor

* RAM - minimum 32 MiB, maximum 1 GiB; 64 MiB atau lebih sangat dianjurkan, kalau mau sekalian dibuat proxy , dianjurkan 1GB... perbandingannya, 15MB di memori ada 1GB di proxy..

* HDD minimal 128MB parallel ATA atau Compact Flash, tidak dianjurkan menggunakan UFD, SCSI, apa lagi S-ATA Very Happy

*NIC 10/100 atau 100/1000

Untuk keperluan beban yang besar (network yang kompleks, routing yang rumit dll) disarankan untuk mempertimbangkan pemilihan resource PC yang memadai.

Lebih lengkap bisa dilihat di www.mikrotik.com.

Meskipun demikian Mikrotik bukanlah free software, artinya kita harus membeli licensi terhadap segala fasiltas yang disediakan. Free trial hanya untuk 24 jam saja.

Kita bisa membeli software mikrotik dalam bentuk CD yang diinstall pada Hard disk atau disk on module (DOM). Jika kita membeli DOM tidak perlu install tetapi tinggal menancapkan DOM pada slot IDE PC kita.

Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan sederhana sebagai gateway server.

1. Langkah pertama adalah install Mikrotik RouterOS pada PC atau pasang DOM.
2. Login Pada Mikrotik Routers melalui console :
MikroTik v2.9.7
Login: admin
Password: (kosongkan)

Sampai langkah ini kita sudah bisa masuk pada mesin Mikrotik. User default adalah admin dan tanpa password, tinggal ketik admin kemudian tekan tombol enter.

3. Untuk keamanan ganti password default
[admin@Mikrotik] > password
old password: *****
new password: *****
retype new password: *****
[admin@ Mikrotik]] >
4. Mengganti nama Mikrotik Router, pada langkah ini nama server akan diganti menjadi “kesitu” (nama ini sih bebas2 aja mo diganti)
[admin@Mikrotik] > system identity set name=kesitu
[admin@kesitu] >

5. Melihat interface pada Mikrotik Router
[admin@kesitu] > interface print
Flags: X - disabled, D - dynamic, R – running
# NAME TYPE RX-RATE TX-RATE MTU
0 R ether1 ether 0 0 1500
1 R ether2 ether 0 0 1500
[admin@kesitu] >

6. Memberikan IP address pada interface Mikrotik. Misalkan ether1 akan kita gunakan untuk koneksi ke Internet dengan IP 192.168.0.1 dan ether2 akan kita gunakan untuk network local kita dengan IP 172.16.0.1
[admin@kesitu] > ip address add address=192.168.0.1
netmask=255.255.255.0 interface=ether1
[admin@kesitu] > ip address add address=172.16.0.1
netmask=255.255.255.0 interface=ether2

7. Melihat konfigurasi IP address yang sudah kita berikan
[admin@kesitu] >ip address print
Flags: X - disabled, I - invalid, D – dynamic
# ADDRESS NETWORK BROADCAST INTERFACE
0 192.168.0.1/24 192.168.0.0 192.168.0.63 ether1
1 172.16.0.1/24 172.16.0.0 172.16.0.255 ether2
[admin@kesitu] >

8. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.0.254
[admin@kesitu] > /ip route add gateway=192.168.0.254

9. Melihat Tabel routing pada Mikrotik Routers
[admin@kesitu] > ip route print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf
# DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
0 ADC 172.16.0.0/24 172.16.0.1 ether2
1 ADC 192.168.0.0/26 192.168.0.1 ether1
2 A S 0.0.0.0/0 r 192.168.0.254 ether1
[admin@kesitu] >

10. Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar
[admin@kesitu] > ping 192.168.0.254
192.168.0.254 64 byte ping: ttl=64 time<1 ms
192.168.0.254 64 byte ping: ttl=64 time<1 ms
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0/0.0/0 ms
[admin@kesitu] >

11. Setup DNS pada Mikrotik Routers
[admin@kesitu] > ip dns set primary-dns=192.168.0.10 allow-remoterequests=no
[admin@kesitu] > ip dns set secondary-dns=192.168.0.11 allow-remoterequests=no

12. Melihat konfigurasi DNS
[admin@kesitu] > ip dns print
primary-dns: 192.168.0.10
secondary-dns: 192.168.0.11
allow-remote-requests: no
cache-size: 2048KiB
cache-max-ttl: 1w
cache-used: 16KiB
[admin@kesitu] >

13. Tes untuk akses domain, misalnya dengan ping nama domain
[admin@kesitu] > ping yahoo.com
216.109.112.135 64 byte ping: ttl=48 time=250 ms
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 571/571.0/571 ms
[admin@kesitu] >

Jika sudah berhasil reply berarti seting DNS sudah benar.

14. Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.
[admin@kesitu]> ip firewall nat add action=masquerade outinterface=
ether1 chain:srcnat
[admin@kesitu] >

15. Melihat konfigurasi Masquerading
[admin@kesitu]ip firewall nat print
Flags: X - disabled, I - invalid, D – dynamic
0 chain=srcnat out-interface=ether1 action=masquerade
[admin@kesitu] >

Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local. Dan jika berhasil berarti kita sudah berhasil melakukan instalasi Mikrotik Router sebagai Gateway server. Setelah terkoneksi dengan jaringan Mikrotik dapat dimanage menggunakan WinBox yang bisa di download dari Mikrotik.com atau dari server mikrotik kita.
Misal Ip address server mikrotik kita 192.168.0.1, via browser buka http://192.168.0.1 dan download WinBox dari situ. Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup dhcp server pada Mikrotik. Berikut langkah-langkahnya:

1.Buat IP address pool
/ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20

2. Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client Pada contoh ini networknya adalah 172.16.0.0/24 dan gatewaynya 172.16.0.1
/ip dhcp-server network add address=172.16.0.0/24 gateway=172.16.0.1

3. Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface ether2 )
/ip dhcp-server add interface=ether2 address-pool=dhcp-pool

4. Lihat status DHCP server
[admin@kesitu]> ip dhcp-server print
Flags: X - disabled, I – invalid
# NAME INTERFACE RELAY ADDRESS-POOL LEASE-TIME ADD-ARP
0 X dhcp1 ether2
Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih dahulu pada langkah 5.

5. Jangan Lupa dibuat enable dulu dhcp servernya
/ip dhcp-server enable 0

kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti sudah aktif.

6. Tes Dari client
c:\>ping www.yahoo.com

untuk bandwith controller, bisa dengan sistem simple queue ataupun bisa dengan mangle
[admin@kesitu] queue simple> add name=Komputer01
interface=ether2 target-address=172.16.0.1/24 max-limit=65536/131072
[admin@kesitu] queue simple> add name=Komputer02
interface=ether2 target-address=172.16.0.2/24 max-limit=65536/131072
dan seterusnya...

salam Ke.S.I.T.U

bee^^

22 komentar:

clothing mengatakan...

thanks atas infonya pak

Khitan Wanita mengatakan...

rumah wasir
pengobatan ambeien
penyebab ambeien
gejala penyakit wasir
pantangan wasir
wasir eksternal
penyebab wasir
cara mengobati ambeien
penyakit wasir
mengobati ambeien
cara pengobatan wasir
jenis penyakit wasir
cara mengatasi ambeien
profil rumah wasir
prosedur pengobatan wasir
foto wasir
testimoni pasien wasir
klinik wasir
klinik wasir semarang
informasi pasien
informasi wasir
artikel wasir
video wasir
pengobatan wasir
cara mencegah wasir
operasi wasir
pengobatan wasir eksternal
10 penyebab wasir
wasir internal
obat wasir
3 tips bagi penderita wasir

Info Bali mengatakan...

Having read this I thought it was rather informative. I appreciate you finding the time and energy to put this content together. I once again find myself spending a lot of time both reading and posting comments. But so what, it was still worth it!

Regards:

Sewa Mobil Murah Di Bali

Cheap Bali Car Hire

Cheap Car Rental In Bali

Sewa Mobil Murah Di Bali

Cheap Bali Car Rental

Sewa Mobil Di Bali

Sewa Mobil Bali

Bali Car Rental

Penyewaan Mobil Murah Di Bali

Penyewaan Mobil Di Bali

Penyewaan Mobil Bali

Rental Mobil Murah Di Bali

Rental Mobil Di Bali

Rental Mobil Bali

Rent Car Murah Di Bali

Rent Car Di Bali

Rent Car Bali

Bali Car Hire

Renting Cheap A Car In Bali

Renting A Car In Bali

Budget Car Rental In Bali

Car Rental In Bali

Sewa Mobil Paling Murah Di Bali

Sewa Mobil Termurah Bali

Jual Velg Mobil mengatakan...

velg mobil honda
velg mobil hyundai
velg mobil mazda
velg mobil mitsubishi
velg mobil nissan
velg mobil suzuki
velg mobil toyota
velg mobil bmw
velg mobil chevrolet
velg mobil ford
velg mobil jeep
velg mobil kia
velg mobil mercedez
velg mobil racing
toko velg mobil
bengkel velg mobil
jual velg mobil
velg mobil murah
velg mobil baru
jual velg jakarta
velg mobil
velg racing
toko velg
jual velg

toko velg mobil mengatakan...

velg mobil bmw
velg mobil chevrolet
velg mobil daihatsu
velg mobil ford
velg mobil honda
velg mobil hyundai
velg mobil kia
jual velg mobil
velg mobil mazda
velg mobil mercy
velg mobil mitsubishi
velg mobil nissan
velg mobil suzuki
velg mobil toyota
jual velg racing
harga velg racing
harga velg mobil
toko velg mobil
velg mobil terbaru
bengkel velg mobil
bengkel velg
velg honda jazz
velg mobil livina
velg honda jazz
velg bmw
velg mobil suzuki
velg mobil ford
velg mobil
jual pelek
pelek racing
harga pelek
toko velg mobil
toko velg racing
bengkel velg racing
bengkel velg
jual velg racing
jual velg mobil
velg mobil
velg avanza
velg xenia
velg livina

Jual Velg Racing mengatakan...

jual velg mobil
toko velg
toko velg racing
jual velg racing
bengkel velg
bengkel velg mobil
jual velg terbaru
velg racing
velg mobil
jual velg
jual velg mitsubishi
jual velg crv
jual velg xenia
jual velg jazz
jual velg bmw
velg bmw
velg terbaru
velg murah
velg suzuki
velg toyota
jual velg honda
velg mobil murah
velg nissan
velg livina
velg fortuner
velg ford
velg terios
jual velg bekasi
jual velg jakarta
velg honda freed
jual velg murah

toko velg mengatakan...

jual velg mobil
toko velg mobil
bengkel velg
bengkel velg mobil
jual velg
toko velg
velg murah
velg racing
velg terbaru
jual velg murah
jual velg racing
velg mobil bmw
velg mobil nissan
velg mobil honda
velg mobil toyota
velg mobil jeep
velg mobil suzuki
velg mobil mercy
velg mobil mitsubishi
velg mobil kia
velg mobil audi
velg mobil bogor
velg mobil dihatsu
jual velg murah
jual velg terbaru
toko velg murah
toko velg toyota
toko velg bogor
bengkel velg bogor
pelek murah
harga velg mobil
jual pelek mobil
jual pelek racing
toko jual pelek
bengkel pelek mobil
jual velg bogor

Jual Velg Racing mengatakan...

jual velg mobil
toko velg
toko velg racing
jual velg racing
bengkel velg
bengkel velg mobil
jual velg terbaru
velg racing
velg mobil
jual velg
jual velg mitsubishi
jual velg crv
jual velg xenia
jual velg jazz
jual velg bmw
velg bmw
velg terbaru
velg murah
velg suzuki
velg toyota
jual velg honda
velg mobil murah
velg nissan
velg livina
velg fortuner
velg ford
velg terios
jual velg bekasi
jual velg jakarta
velg honda freed
jual velg murah

Selvi Ratna Ardianti mengatakan...

Your blog has some of the most fascinating information! I've read several pages here and I just had to comment and let you know that I thought you've been doing a great job here. Keep it up!
thanks...
Soal CPNS

toko velg mengatakan...

velg mobil honda
velg mobil hyundai
velg mobil mazda
velg mobil mitsubishi
velg mobil nissan
velg mobil suzuki
velg mobil toyota
velg mobil bmw
velg mobil chevrolet
velg mobil ford
velg mobil jeep
velg mobil kia
velg mobil mercedez
velg mobil racing
toko velg mobil
bengkel velg mobil
jual velg mobil
velg mobil murah
velg mobil baru
jual velg jakarta
velg mobil
velg racing
toko velg
jual velg
velg mercy brabus
velg bmw
velg jazz
velg mercy
velg bmw
velg fortuner
velg mobil cheroke
velg mobil fortuner
velg mobil mercy
harga velg racing
pelek mercy
velg serena
jual velg crv
jual velg fortuner
jual pelek mercy
toko velg terbaru
jual velg bmw

budidaya kenari mengatakan...

Can I just say what a relief to find someone who actually knows what theyre talking about on the internet. You definitely know how to bring an issue to light and make it important. More people need to read this and understand this side of the story. I cant believe youre not more popular because you definitely have the gift. Budidaya Kenari

toko velg mengatakan...

velg mobil bmw
velg mobil chevrolet
velg mobil daihatsu
velg mobil ford
velg mobil honda
velg mobil hyundai
velg mobil kia
jual velg mobil
velg mobil mazda
velg mobil mercy
velg mobil mitsubishi
velg mobil nissan
velg mobil suzuki
velg mobil toyota
jual velg racing
harga velg racing
harga velg mobil
toko velg mobil
velg mobil depok

Obat Sipilis Apa mengatakan...

thanks infonya gan

Obat kencing nanah Apa mengatakan...

thakns infonya

obat wasir mengatakan...



Suwun booss... Artikele apik tenan he..!!
nderek langkung badhe sebar kabar kangge ngobati wasir kula gadah obat ingkang ampuh lan aman kangge njenengan sedoyo

monggo dipun tumbas nopo dipun tulung sebaraken njih. matur suwun.

cara mengobati ambeien
cara mengobati ambeien luar
cara mengobati ambeien alami
cara mengobati ambeien eksternal
cara mengobati ambeien yang sudah keluar
cara mengobati ambeien yang sudah parah
cara mengobati ambeien secara cepat
cara mengobati ambeien alami
cara mengobati ambeien internal
cara mengobati ambeien usai melahirkan
cara mengobati ambeien akut
cara mengobati ambeien alami
cara mengobati ambeien pada ibu hamil
cara mengobati ambeien dengan cepat
cara mengobati ambeien berdarah

iklan baris gratis mengatakan...

Ini artikel yang bermanfaat sekali, terima kasih.
iklan gratis
pasang iklan gratis

fuad silvia mengatakan...

[>>>] Cara Mengecat Velg Mobil Sendiri Dengan Mudah


[>>>] velg balistick ring 22 use mobil outlander


[>>>] Velg Mobil HSR dan TKB Group Indonesia


[>>>] velg mobil untuk daihatsu sirion ring 17 giovana


[>>>] Tips Memilih Warna Velg Mobil Yang Sesuai





[>>>] suzuki swift use velg vosen cv5 ring 17


[>>>] Resiko Menggunakan Velg 18 Inci Terhadap Kinerja Mobil


[>>>] velg mobil bmw ring 19 bmw m6


[>>>] Velg AC Schnitzer Ring 17


[>>>] Untung Rugi Menggunakan Velg Mobil Rim Besar






[>>>] Istilah Pada Modifikasi Velg Mobil


[>>>] Modifikasi Dengan Velg Mobil Ukuran Besar Namun Tetap Nyaman


[>>>] Pengaruh Bahan Dasar Material Velg Mobil


[>>>] Velg Giovanna Ring 17


[>>>] a






[>>>] Tips dan Trik Dalam Mengganti Ban Dan Velg mobil


[>>>] velg mobil terbaru ring 17 turbo


[>>>] Tips Mengganti Velg Mobil dengan Velg Racing


[>>>] bursa velg mobil ford fiesta ring 17 hre


[>>>] Tips Memilih Velg Racing Mobil Model Terbaru

NahCoupons mengatakan...

runman4tt | Coupon Codes | runman4tt | Printable Coupons

Kohls Printable Coupons
Macys Printable Coupons
Best Buy Printable Coupons
DSW Printable Coupons
Sears Printable Coupons
Jcpenney Printable Coupons

Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons
Printable Coupons

payu mengatakan...

telinga bernanah
telinga berdengung
kondiloma akuminata
toksoplasma
telinga bernanah
serangan stroke
obat kencing berbusa
obat susah bab
eksim kering
hematuria

kurap selangkangan
hematospermia

blueberry mengatakan...

virus tokso
mata kering
infeksi torch
tinnitus
epididimitis
gonore
pembesaran prostat
kencing terasa sakit

Rahayu Ningsih mengatakan...

Thanks ya sudah berbagi pengetahuan yang bermanfaat.
pasang iklan gratis tanpa daftar
pasang iklan gratis di internet
pasang iklan baris gratis

Desti Herbal10 mengatakan...

thanks
for the
great
article
and informations
keep on
a good work
buddy
, please visit
my web too
click here